It is currently Fri Jul 20, 2018 9:11 pm


Underperforming Rig?

All computer hardware support

Underperforming Rig?

Postby Xjordanary » Fri Dec 17, 2010 5:28 pm

Hey people, this may just be my foolishness (which is probable) but i am noticing that the pc gaming rig i recently got is not exactly living up to scratch, even though i 'think' it should be (again, im not entirely clever).

Basic Specs:
Intel i7 960 3.2ghz
6gb RAM
ati radeon hd 5970 2gb ddr5

Basically games that should be able to run on this setup with minor fps drops (such as crysis, gta IV) are not, and appear to be running slower with high settings. Again this could just be my foolishness, and this rig isnt infact great, but i believed it to be when i got it. Most games still run well (such as Just cause 2, batman arkham assylum, stalker cop)

-I have latest catalyst controll center
-I am NOT overclocking my cpu(though im guessing this will be most suggested to allow 5970 to run optimally)
-I have tried changing settings around in the catalyst control centre

Oh and I wasnt sure whether this post would be better for hardware or gaming :P

Any help would be really appreciated to optimise what i have...
help out a technologically-challenged user :D
Thanks :)
Xjordanary
Newbie
Newbie
 
Posts: 2
Joined: Fri Dec 17, 2010 5:17 pm

Thanks given:0
Thanks received:0
Top

Re: Underperforming Rig?

Postby liljim » Fri Dec 17, 2010 8:21 pm

That machine should run great and no, i actually dont suggest OC'ing the cpu. Theres usually not enough gain from it to justify the extra heat output. It really dont do very much for your gpu anyhow but again, that particular gpu shouldnt be having any problems to begin with. Have you downloaded fraps and compared actual framerates? Id start with that and lets see just exactly what amount of loss your seeing.
User avatar
liljim
Moderator
Moderator
 
Posts: 3017
Joined: Mon Mar 03, 2003 1:00 am
Location: Louisiana
Operating System: Win 7 Home Premium X64

Thanks given:0
Thanks received:12
Top

Re: Underperforming Rig?

Postby Xjordanary » Sat Dec 18, 2010 5:47 am

liljim wrote:That machine should run great and no, i actually dont suggest OC'ing the cpu. Theres usually not enough gain from it to justify the extra heat output. It really dont do very much for your gpu anyhow but again, that particular gpu shouldnt be having any problems to begin with. Have you downloaded fraps and compared actual framerates? Id start with that and lets see just exactly what amount of loss your seeing.


Thanks for replying. I mentioned overclocking because i did some research before posting this and ppl seem to get a boost in performance when oc'ing to bout 3.4-4ghz, though i dont have an after market cooler so oc'ing is basically out of the question atm anyway :)

Yep i tried it with fraps and im even more depressed now - fps is probably averaged at about 30fps and drops as low as 12... most is about 50 when im inside with little going on (GTA IV maxed out)...

any ideas?
Xjordanary
Newbie
Newbie
 
Posts: 2
Joined: Fri Dec 17, 2010 5:17 pm

Thanks given:0
Thanks received:0
Top

Re: Underperforming Rig?

Postby liljim » Wed Dec 22, 2010 2:57 am

yea thats no doubt under performing. Have you updated your motherboard drivers? Somethings definatly not putting out but hard to say what.

Swing through PcPitstop.com and run their test. It might help narrow down where the bottleneck is taking place. Run it in Internet Explorer, it works better with the test for some reason. Let us know the results.
User avatar
liljim
Moderator
Moderator
 
Posts: 3017
Joined: Mon Mar 03, 2003 1:00 am
Location: Louisiana
Operating System: Win 7 Home Premium X64

Thanks given:0
Thanks received:12
Top


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

cron